Customers not getting their signed documents back from RightSignature
Incident Report for SmartVault
Resolved
The RightSignature] service is back online and fully operational. We sincerely apologize to all of our customers impacted by this intermittent disruption.
Posted Oct 03, 2017 - 11:35 CDT
Identified
Our engineering team has been able to diagnose the issue that caused the intermittent disruption, and the service should be confirmed as restored by Tuesday, 1 pm.
Posted Oct 02, 2017 - 16:15 CDT
Investigating
The RightSignature service is experiencing intermittent service interruptions. We are working diligently to resolve this disruption in service, and we apologize to those customers that are currently impacted. We will provide an update by 3 pm.
Posted Sep 29, 2017 - 12:20 CDT