Phone Support is offline
Incident Report for SmartVault
Resolved
SmartVault Phone Support has been restored. We sincerely apologize to all of our customers impacted by this incident.
Posted Aug 08, 2017 - 12:35 CDT
Identified
SmartVault Phone Support is offline. This is due to a power outage in our main office. Phone support will be restored once power has returned. Please note that LiveChat support is available. Thank you for your patience.
Posted Aug 08, 2017 - 09:29 CDT